[EPC-R7200]About building an environment on the host

Currently my EPC-R7200 (XavierNX 8GB) references the Linux Flash eMMC Method to write DIV0003 and is ready to use the Ubuntu 18.04 GUI.
I am struggling to build an environment while referring to the page below.
I would like to eventually install Jetpack 4.6.1 and use a library like Pytorch.
Docker command:

docker pull advrisc/u18.04-imx8lbv1

The response to this command is shown below, so I assume you are able to pull the image.

Using default tag: latest
latest: Pulling from advrisc/u18.04-imx8lbv1
Digest: sha256:4f0e4f76a9e6cbfa8b53df9102db4b41e4376fec01d9c6654f53c8523ab5132d
Status: Image is up to date for advrisc/u18.04-imx8lbv1:latest

I got a warning when I ran the container.

ubuntu@linux:~$ sudo docker run -it --name jetson_linux_risc -v /home/bsp/myLinux:/home/adv/BSP:rw --privileged advrisc/u18.04-imx8lbv1:latest /bin/bash
WARNING: The requested image’s platform (linux/amd64) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested
exec /bin/bash: too many levels of symbolic links

[sudo apt-get install qemu-user-static] has also been run.
I also went ahead and tried it but it did not work.(Remove “https” from the actual reply)

ubuntu@linux:~/BSP/jetson_linux_risc$ sudo repo init -u ://AIM-Linux@dev.azure.com/AIM-Linux/EPC-R7200/_git/manifests -m 3271.xml
fatal: Cannot get ://gerrit.googlesource.com/git-repo/clone.bundle
fatal: error [Errno 101] Network is unreachable

Sorry for the basic question.
Any tips would be appreciated.

1 Like


The Jetson OS image DIV0003 we provided already uses jetpack 4.6.1.

Check the image with cat /etc/nv_tegra_release and return R32.7.1. Compare with the Jetpack Archive version and the version released with Jetpack 4.6.1.

You can reference the link below to install Jetson Software with SDK Manager:

The OS image we have provided R32.7.1(DIV0003). It seems you have flashed to eMMC so please uncheck the Jetson OS when installing the SDK component.

Or can reference the Advantech wiki to install the SDK component.
Ubuntu L4T User Guide - ESS-WIKI (advantech.com.tw)

After the SDK component has been installed, you can reference the link below to install Pytorch:

Tell me about your host PC and OS?
Dell? HP? NEC? Fujitsu?
Ubuntu? 18.04?

The host machine is an MSI GF63-10UC-696JP.
The OS is Ubuntu 18.04.6LTS.

I can confirm that cat /etc/nv_tegra_release currently returns R32.7.1.
There was a problem with the apt not coming through in the SDK manager, which is being resolved.

Unable to connect to Jetson module using SDK Manager.
I have confirmed that it is detected on the host PC side with lsusb and with the SDK manager.
I could not use the default IP on USB.
On Ethernet I get the following message
Cannot connect to the device via SSH. Check the user name and password, and make sure that the SSH service is running on the device.

I can boot the module normally and log in to the module from the host PC using the ssh command.


The default IP is “”
Could you check the USB device connect to the host by command “lsusb” and check there is a 0955:7020 Nvidia Corp(Xavier NX) and you can pin “” successfully

And use ssh to login to the Xavier NX “”
ssh ubuntu@
PW: ubuntu

Install SDK component by sdkmanager

1 Like

Sorry it took me so long to try it.
I have pinged the system but it is NG.

~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0955:7e19 NVidia Corp.
Bus 001 Device 003: ID 8087:0026 Intel Corp.
Bus 001 Device 002: ID 5986:211b Acer, Inc
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
~$ ping
PING ( 56(84) bytes of data.
— ping statistics —
11 packets transmitted, 0 received, 100% packet loss, time 10247ms

The EPC-7200 is connected to the host in recovery mode with a USB cable.
I also tried the ping option -r, but it did not reach the network.
The network could not be reached by ping in either a proxy or non-proxy environment.


Recovery mode is used for flashing OS image so you cannot ping the target devices successfully in recovery mode. It can only be used to flash OS image to the target in recovery mode. After the OS image has been flashed to the target, then you can use the Micro USB port (l4tbr0 IP Addr: to install Jetson SDK components. Check the IP Addr in the target ubuntu OS. The IP Addr is in “l4tbr0”


  1. Please make sure that your target device (Xavier NX) has flashed the OS image.
  2. Power on the Xavier NX system and connect the micro-USB cable to your Ubuntu host system (Type A)
  3. Now it can ping The default USB IP address is
1 Like